Recording at 96kHz with USB input

I'm trying to record at 96kHz with my USB mic.
I init AEAudioController for input only and with an audioDescription at 96k 24 bit (tried 32bit float as well).

Recording goes without error and when I launch the app with the mic connected, I've got a successful 96k message in console:
TAAE: Audio session initialized (input available, audio route 'iXY') HW samplerate: 96000

But if I look at the spectrum it is clear that there is nothing but resample noise above 20kHz:

For comparison this is a spectrum of the same recording using the app bundled with the USB mic:

I've tried setting AEAudioControllerOptionUseHardwareSampleRate and a lot of other things, but it doesn't change anything.
Is there anything else I must do to record at native 96kHz?
Or maybe the app bundled with the USB mic (Røde Rec) communicates with the mic with proprietary protocol and I'm out of luck here?


  • I've seen a comment in [AEAudioController initWithAudioDescription:inputEnabled:useVoiceProcessing:outputEnabled:] method:

    * @param enableOutput Whether to enable audio output. Sometimes when recording from external input-only devices at high sample rates (96k) you may need to disable output for the sample rate to be actually used.

    So someone might already face this problem.
    (I disable output as the comment suggests)

Sign In or Register to comment.