Problem finding new AudioUnit filters with CocoaPods install update to 1.5?

edited September 2015

@Michael,

I updated my Xcode project with TAAE using 'pod install' from 1.4.8 to version 1.5. But, I noticed that it didn't include the new Modules AudioUnit filter wrappers directory. So, I downloaded the master zip file from GitHub, and dropped the Modules directory into TAAE directory within the Pod folder. When I attempt to build my app, I received 10 build errors, which look like this:

/Users/.../Modules/Filters/AEHighPassFilter.m:22:18: No visible @interface for 'AEHighPassFilter' declares the selector 'getParameterValueForId:'

When I build and run TheEngineSample from the latest TAAE master.zip, the project deploys successfully, without a errors. So, I'm just wondering if I'm placing the Modules folder into the wrong location, since I'm using CocoaPods for the installation. I hope that this isn't too trivial.

Thanks in advance,
Mark

Comments

  • Hey @markjeschke,

    I've not actually released the new code yet - it's still just in the master branch, so it's not in Cocoapods. If you want to use it right now, you'll probably need to include the modules directly within your app's project.

  • edited September 2015

    I tried that, @Michael. But, I'm receiving errors that cause the build to fail. This is 1 of 10 errors that I'm receiving from the Modules filter classes:

    /Users/.../Modules/Filters/AEHighPassFilter.m:22:18: No visible @interface for 'AEHighPassFilter' declares the selector 'getParameterValueForId:'

    I tried placing the Modules folder in the root level of my project, and within TAAE directory inside of the Pods folder, but it doesn't seem to correct the build errors. Can you please point me in the direction for where I should manually place the Modules folder so that it hooks up with TAAE correctly? Or, should I remove TAAE's directory location from the Pods directory, so that it matches the TheEngineSample?

    This isn't a show-stopper, so I can also just wait until you officially release the new code. :)

    Thanks again,

    Mark

  • edited September 2015

    Ah, you also need to update your Podfile to point to the latest commit of TAAE, too (the syntax temporarily escapes me, but something like pod 'TheAmazingAudioEngine', :commit => '3c3aded094b7e42f71673bdce01852c7cfaed19f'

    Come to think of it, that might even be enough to get the modules too.

  • Thank you for the info, @Michael. I'll keep you posted with my progress. Thanks again for creating and sharing such an amazing and useful audio engine. :)

  • You're most welcome, and thanks =)

Sign In or Register to comment.