ARC

edited March 2013

I added all the files that are in the Modules group to my project then added the ARC flag so they would not be a problem in my project that has ARC turned on. I build and it complains about all the files that are in the sub project "TAAE". This does not make sense to me. I even checked TAAE to see if somehow ARC got turned on but no it is off. Why is ARC messing with TAAE sub project anyway? What am I missing?
Thanks in advance for any pointers.

Comments

  • Whoa - actually, I have no idea! That doesn't really make sense to me either. You definitely dragged TheAmazingAudioEngine.xcodeproj in, and not the folder?

  • edited March 2013

    I draged only the .xcodeproj file in then i drug the Modules folder in like the documentation said to and used the flag on them. They are not the problem.

    Note the attached image. Maybe you'll see something there I don't. Note that ARC has a problem with the AEMixerBuffer in TAAE project not the reference that is in my project. It did at first but then I used the flag on it.

  • Well I don't know what went wrong but since I had done no coding in the project I created a new one and started from scratch. Everything worked great! I wonder if it had anything to do with the fact that I had the Example project open when I created my project the first time around. I say this because I noticed that Xcode doesn't know what to do when two different projects are open that have the same sub project in them. So thinking that may have started everything off on the wrong foot so I tried while nothing else was open in Xcode and wow it works perfect.

  • I spoke too soon... I still had problems but know I think I have it figured out and will just document it here for the other unexperienced like me. :)

    What I was doing was dragging the Modules folder form the sub project that I had previously pulled in from Finder. That is not to be done I guess. After pulling in the Modules folder from Finder all is perfect.

Sign In or Register to comment.