preferredBufferDuration

edited June 2013

Hello

I have just migrated my app from a basic simple audiounit (output only, it is a physical modeling synth) to TAE, and everything was quite easy and works fine.. thanks for the documentation and the forum for answering most of my question... and for the TAE quality ...

My app allows setting of the Audio Buffer size (from 256 to 2048 for slow devices like 3GS).
But it doesn't work any more with 2048 (so preferredBufferDuration=0.04644) and I get an error "AEAudioUnitFilter.m:209: AudioUnitRender result -10874 FFFFD586 ˇˇ’Ü" (I guess this is from the Reverb2 filter I have added) and a quite awful audio.

Is there anyway to have the 2048 buffer size to work with TAE ?

Comments

  • Does this fix the problem, @Anckorage?

    UInt32 maxFPS = 4096;
    AudioUnitSetProperty(filter.audioUnit, kAudioUnitProperty_MaximumFramesPerSlice, kAudioUnitScope_Global, 0, &maxFPS, sizeof(maxFPS));
    
  • Thanks for the answer, but no, I still have the same error message.
    I have also tried it on the audio controller.audioUnit, with no success ...
    I did a try without the Apple Reverb2 (so only my synth): in this situation I don't get the same error message, I have "TAAE: Timed out while performing message exchange" (but not always)
    And there is no more audio...
    Everything is Ok as soon as I come back to 1024.

    What is also strange is that when I ash 2048 there is a message saying "Buffer duration 0.023, 1024 frames (requested 0.046s, 2048 frames)"
    When I ask back for 1024, I have "Buffer duration 0.046, 2048 frames (requested 0.023s, 1024 frames)"
    So it says that buffer is set to 2048 when I require 1024 !

Sign In or Register to comment.