TAAE2 - I can't change to another .mp4 sample

edited May 2016

Hello I followed the video example and when I tried to change the amen.mp4 to another imported .m4a sample I get this error

by the way it works fine with the amen or other audio files in .mp3, .wav or .aiff but not .m4a


  • Hey - in the screenshot you posted, module is nil; AEAudioFilePlayerModule returns nil to indicate that the file load has failed. Use the error output parameter on AEAudioFilePlayerModule's initialiser to determine why.

  • edited May 2016

    I get this :) which I have my file copied in the audio folder and I can even play it in xcode when I double click on the file.

  • edited May 2016

    Hey Michael I forgot to check the "add to target" box when adding an audio file

    But I noticed when I use other original samples i.e. mp3,wav,m4a there's a pop at the end of each sample for one shots(not loops).
    I tried cheap converters to convert to wav -> m4a to see if that gets rid of the ugly pop and didn't work,
    but something that worked was using the sound forge convertr demo wav -> m4a and it got rid of the pop.

    just some notes :)

  • Oh, interesting! Any chance you could attach (or email me) a sample that exhibits this issue? Sounds like a bug in the player's microfade code, perhaps, unless the sample itself has a discontinuity at the end.

  • edited May 2016

    Yes the samples plays fine on any player, as you can see it plays a normal clap.wav with a pop at the end. When you try other samples, you can still hear a pop at the end, but not with the original m4a loops(amen,bass, etc..)

  • Ah-ha! Thanks for that, it looks like there's a bug in the underlaying audio unit that's not correctly reporting its initial timeline position. I've replaced it with my own code to keep track of the position, now it works. Grab the latest version, should work correctly now.

Sign In or Register to comment.