Has anyone else successfully followed along the TAAE2 video with success?

I followed the examples as closely as I could.
Everything compiles until I add #import "AEDemoAudioController.h" to the bridging header file.

When attempting to compile, it fails at the first line with:


  • edited April 2016

    Hey i made it work somehow,
    i got temporary solution I think. I made a TAAE2-master duplicate and edited the TAAE Sample .m and .swift files to start with the sine wave, it worked in my ipad pro and the simulator.

  • Hey @fbunn - Ah, yes, if you're using the same architecture (an Xcode workspace with the app as a subproject), then you need to do a bit of messing with the header search paths. Take a look at the TAAE2 sample app's project settings; you'll find "$(BUILT_PRODUCTS_DIR)" in the header search paths for the debug build, and that as well as "$(TEMP_ROOT)/UninstalledProducts/$(PLATFORM_NAME)" for the release build.

  • Thanks, Michael! I'll give that a whirl :)

  • I have a similar problem. I tried building a sample from scratch using the video.

    Using the sample project from GitHub with the sample project tree I get the following errors:

    I can edit the #import </TheAmazingAudioEngine/TheAmazingAudioEngine.h> path to absolute path on my computer but then the project does not find The Amazing Audio Engine modules:

    Any ideas? Thanks!

  • You've got a typo there in AEAudioController.h:12: #import </The.... Gotta remove that leading "/". I just checked, it doesn't seem to be there in the repository.

  • Not sure how that / got in there. I still get the same error.

    Here is other change I made (the debug and build locations listed above):

    Thanks for the help.

  • edited May 2016

    Hmm, maybe just revert all changes/delete and re-download?

    Edit: Oh! You've opened the Xcode project for TAAESample, not the Xcode workspace, that's why. Open the workspace, and it'll work.

  • yes. That is what I did wrong. Open the workspace not the Xcode project. Thanks.

  • I've just started trying out TAAE2 and love the stack approach to processing buffers. But would it be hard to make this available via Cocoapods?

  • I haven't tried the cocoapods install yet but I'm pretty sure it is already available :)

  • It'll definitely be made available on Cocoapods soon - currently, there's just 'TheAmazingAudioEngine' (TAAE 1). Soon there'll be TheAmazingAudioEngine2, but only once I've hit a solid version 1.0. That won't be far off, though.

Sign In or Register to comment.