Unable to include "TheAmazingAudioEngine.h"

edited March 2013

I followed the instructions on adding The Amazing Audio Engine to my project but I am not able to include it in my source file. I don't feel like I missed a step but I'm not sure what is going on. I am updated to all the latest xcode / ios updates.

Here are two screen shots which show my current setup and the error:

http://www.readmymime.com/1.png
http://www.readmymime.com/2.png

Thanks for the help in advance!

Comments

  • I changed the import to "TheAmazingAudioEngine/TheAmazingAudioEngine.h" which took away the error until I tried to build in which the error came back saying that couldn't be found anymore...

  • Hi @charlie_ray,
    Ah, my bad - I missed a step in the setup guide. You need to set the Header Search Paths appropriately. Here's the content I just added:

    In the "Build Settings" tab, find the "Header Search Paths" item and add the path to the "TheAmazingAudioEngine" folder. For example, if you put the distribution into "Library/The Amazing Audio Engine", you might enter "Library/The Amazing Audio Engine/TheAmazingAudioEngine".

  • That fixed it thanks! I was able to make it work earlier by using absolute path but this will definitely help in the future. Great library! Was able to program something in 10 minutes that previously took me days to figure out...

  • That's great to hear! And thank you!

Sign In or Register to comment.